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ADVANCED MASKING TECHNIQUES 
Masking creates the effect of a stencil on artwork, for selective alteration of an image.  This 
lesson shows how to use a variety of techniques to create masks for special effects by working in 
a channel. 
 
As you learn masking techniques, you will continue to work with channels using progressively 
more advanced techniques.  You will create a series of images as you complete three projects 
using the Blues file supplied with the tutorial. 
 
In this lesson, you will learn how to: 
• offset selections 
• create shadows using layers 
• create a gradient fill within a mask 
• create a mask through which one image fades into another using the Calculate command 
• create an image from separate images using the Easy Palette Masks 
 

CREATE A SHADOW USING MASKS  
In this project, you will use special effects to create new backgrounds from an existing file. 

 

Constructing the object casting a shadow  
You begin by adding the image that will be used as a mask and that will be the object casting a 
shadow in your artwork.  To add the image, you will construct the base image using 
PhotoImpact. 
1. Open a new file that measures: 486 x 396.  Make sure that your dimensions are precise, this 

is important for a later step. 
2. The size of the image we will build within the window is not as precise as the size of the 

window itself.  As we start drawing the circles and lines within this area, you can make them 
any size you wish. 

3. Start by selecting the Shape Tool.  
4. On the Attribute toolbar select the circle tool and set the color to black.  
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5. Draw a black circle at the center of the window. 
 

 
 
6. Deselect the black circle by selecting Selection>None. 
7. Change the color on the Attribute bar to white, draw a smaller circle and place it within the 

larger black circle. 
 

 
 
8. Next we’ll add some long rectangular lines to our image.  You will do this by selecting the 

Shape Tool.  On the Attribute bar, select the rectangle shape, set the color to white, and draw 
a long thin rectangle vertically through the center of the two circles. 

 

Place the circle just 
above the center of the 
space. 

Select both circles using the 
Selection tool.  Use 
Object>Align>Center Both 
the center the two circles within 
themselves.  This makes them 
concentric circles. 
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9. With the slim rectangle line still selected, Copy it to the clipboard.  Deselect the 

original vertical line and Paste a new line.  Drag it over the top of the first line. 
10. Select the Transformation Tool.  
11. In the Rotate by degree box, type in 45 and click the counter clockwise icon to the left. 
 

 
 

 
 
12. Continue this process until you have the following image. 
 

Don’t worry about it 
extending beyond the 
circle.  It won’t matter 
later. 

If you have problems, press 
the Delete key and try again. 
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13. With all of the “Spokes” selected, center the spokes by selecting Object>Align>Center 

Both. 
14. To make the image look a little less symmetric, we will rotate the entire image 22 degrees.  

This time set the “Rotate to Degree” to 22 and click either rotation arrow icon. 
 

 
 

 
 
15. Once your satisfied with your image, use the Object>Merge All to combine all of our layers 

together. 
 

 
 

For this next step, select each of 
the “spokes” by click on one 
spoke and then hold down the 
“Shift” key while selecting the 
remainder of the spokes. 
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CONVERTING THE IMAGE 
 
1. We have actually merged all of our layers together so that now we have a black image on a 

white background. Much like a black image printed on a white piece of paper. 
2. To achieve a three view, we need to cut our image out and place it on it’s 

own layer. 
3. Select the Magic Wand Tool.  
4. Click the White background of our image.  You should see a dotted line surrounding your 

window and the image.  Select Selection>Invert to choose just the image. 
 

              
 
5. To create this image on its own layer, select Selection> Convert to Object.  If you switch to 

the Rectangular Selection Tool, you will notice that you can now move the image 
around within the window.  

6. Now is the time to save our image.  Select File>Save.  Save your image as a .ufo type. This 
will preserve our layers.  Give it the name: Logo.ufo. 

 

ADDING TEXT TO THE IMAGE 
 

1. We’ll now a text to our image.  Start by selecting the Type Tool.  
2. Click once on the image to activate the Attribute toolbar. 
 

 
 
3. Set the Font to Impact, the size to: 36 and the color to 

Black. 
4. Click once again on the image and the text box will 

appear. 
5. Type in a capital “M” and click “OK”.  Drag the “M” 

into the center of the circle. 
6. Continue these steps until you have “C” and “S”.  

Dotted Line 
around 
outside and 
circle 

Dotted Line 
around inside 
circle only. 
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Arrange them in the center of the circle as shown below.  You should be able to move each 
letter individually to place diagonally across the center of the circle. 

 

 
 
7. Next, using the Type Tool to add in the text: Instructional Technology, at the bottom of the 

circle. 
 

 
 
8. Save this image again as: Logo.ufo. 
9. Lastly, use the Arrow selection tool to draw a rectangle around all of the image components.  

You should see dotted lines around all of the components.   
10. Select Object>Combine as a Single Object.  We’ve now combined all of our components 

into one image.  Don’t deselect the image. (Leave the dotted lines around the image) 
 

ADDING A COLOR FILL TO THE IMAGE 
 
1. Open the Blues file located in the Tutorial folder. 
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2. With the blues file as the active window, select Selection>All to select the entire image. 
3. On the Standard toolbar, click the Copy button. 
4. Return to our Image by clicking anywhere on the title bar at the top of the image window. 
5. Select Edit>Paste>Into Selection.  Position the color fill where you wish to have it and click 

once to place the color fill. 
 

 
 
6. To add a shadow behind our image, make sure that 

the image is selected and right-click.  Select 
Shadow from the menu.  

 

 
 

Save your work as: LogoFinal.ufo   If 
you were to use this on a web page for 
example, then you would want to save 
this image again using the “.jpg” 
format.  .ufo files are only good inside 
of PhotoImpact. 
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CREATE A COMPOSITE IMAGE USING A MASK 
In this project, you will superimpose two images through a mask to create a composite image.  
Essentially, you will create a "sandwich" of three images: a foreground image, a mask, and a 
background image.  Remember that to use any calculation command, all three images must be 
exactly the same size.  Now you know why we created the last image to a specific size.  We will 
be using our image as the “mask” in this process. 

Create the foreground image  
You will use the Blues file again, as one of the sources for the composite image.  The Blues file 
will become the background of the composite image. 
 

1. Open the Blues file located in the Tutorial folder. 
2. Open the Gold file also located in the Tutorial folder. 
3. Open the Logo.ufo image you saved earlier.   

 

     
 

4. Remember, all of these images must be the same size. 
5. Select the Logo.ufo image and Select 

Object>Merge All to merge all of our layers 
together.  There is no need to save the image again, 
since we will only use it as a mask for the 
calculation.  When you close the Logo image and 
PhotoImpact asks if you wish to save the changed 
image, select NO.  This will make sure we always 
have the layered image to work with at a later date. 

6. Next select Format>Convert Data 
Type>Grayscale to change our image to a 
grayscale image rather than an RGB image.  

 
Now we’re ready to calculate! 
 

7. Start by selecting the Blues.jpg file as the active 
image.  It will act as our background to our calculated image.  It is generally easier to 
start with the background image as the default image; however, not to worry if you 
forget, you can always change it later from the pull down menus. 
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8. Next, evoke the calculation function by selecting Format>Calculation.  You should get 

a window that looks like the following: 
 

 
 

9. Notice that Blues.jpg is selected for both the foreground and background color and no 
mask is selected. 

10. From the Background pull-down menu select the Gold.jpg file. Notice the preview 
thumbnail at the end.  

11. Next place a check mark in the Mask check box. It will automatically select the 
foreground image for the mask.  Notice again the preview.  PhotoImpact is colorizing the 
end product by merging the color channels together.  Interesting effect, but not what 
we’re after. 

12. From the pull-down menu under the Mask option, select your Logo file.  The final screen 
should look like this: 
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13. Notice the preview box.  Try switching the Gold and Blues file in the foreground and 
background to see what affect it has on the image outcome. 

 

 
 

ADDING A SHADOW TO THE FOREGROUND IMAGE 
 

1. We’ll now add a shadow to the foreground image.  When the images where merged 
together through the calculation function, it came out as one image- not layered.  

2. To get a shadow under our foreground image, we will first need to separate it from the 
background image and place it on it’s own layer. 

3. To do this we’ll return to our Magic Wand tool.  
4. This will bring up the Attribute toolbar for the wand. 

 

 
 

5. Because our foreground has an aggregate 
color with various shades of gold, you will 
need to click on several part of the 
foreground to select the entire foreground 
image.  To cut down on the number of time 
we will need to click on any one 
component, set the “Similarity” option to 
96 and make sure there is a check mark in 
the “Search Connected Pixels” box.  The 
96 in the similarity box will allow us to 
select a wider range of colors to include in 
the capture and the search option makes 
sure the application will search outward for 
similar pixel colors. 

Our final image should 
look like the illustration to 
the left. 
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6. As you can see in the illustration, you may have to click in several locations to include 
the entire image and all of its components.  This by far is the most tedious part of the 
operation.  Be sure to click on each one of the text letters until the entire foreground 
image including letters have been selected. 

7. To place this on it’s own layer select Selection>Convert to Object.  The foreground 
image has now been cut out and is now on it’s own layer.  NOTE:  Like any cut out 
pattern, if you move the image you will see a white space left behind.  However, we’re 
going to use this to our advantage. 

8. Find your cursor arrow keys on your keyboard and press the up arrow once and the left 
arrow once.  This will expose a small portion of the white cut out background giving us a 
little dimension to our letters and image. 

9. Next, right click on the foreground image and select Shadow. 
 

 
 

10. Place a check mark in the Shadow check box, activating the shadow feature.  Notice that 
the shadow color is set to black.  Click the color box once and select the yellow color tab 
and one of the brighter yellow colors. 
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11. When the Shadow dialog box returns, click the OK button to see the results of our little 

experiment in masking.  Save your new image as: LogoColor.ufo.  If you were going to 
use this image in a document or on the web, you might wish to save it again as a .jpg file. 

 

 
 

THE FINAL MASKING PROJECT – THE EASY PALLETTE WAY 
 
You knew that there must be an easier way to use masks then what we’ve been through.  Well, as 
usual, I’ve saved the easiest to last, just for fun.  PhotoImpact as some predefined masks that we 
can use to create some interesting effects. 
 

1. Start by opening up the Blues.jpg file once again.  
2. If the Easy palette is not active, look toward the right end of the Standard 

Toolbar for the Easy Palette button and click it once to open the palette.  
3. The Easy Palette should open.  
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4. Click on the second icon over from the left. 

 

 
 
 

5. This will bring up a library of object that you can use with your images.  Basically, this 
images and objects can be dragged to the image workspace to be included. 

6. Click on the second library down labeled – “Mask Library”.  You will see a host of mask 
shapes that can be used with your image. Scroll down to find the mask labeled “Rays 5”.  

 

 
 

7. Drag this mask on top of the Blues.jpg image and release the mouse.  It’s not necessary 
that it be centered, just inclusive within the image. 
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8. You should see the outline of the shape on your Blues.jpg image. 
9. Use the Edit>Copy function to place a copy on the clipboard.  A copy of what you say?  

Just wait. 
10. Open a new Image window with the size of 486 x 396.  Once the new image window 

opens, paste your image from the clipboard to the new image window.  Does it look like 
this? 

 

 
 

11. Impressed yet?  Let’s add a little something more. 
12. Open your Logo.ufo file. 
13. Select Object>Combine as a Single Object.  We’ve now combined all of our 

components into one image.  Don’t deselect the image. (Leave the dotted lines around the 
image) 

14. Open the Gold.jpg file.  Use the Selection>All to select the entire image. Use 
Edit>Copy to paste a copy of Gold on the clipboard. 

15. Select your Logo file and use the Edit>Paste>Into Selection to paste the Gold fill into 
the logo image. 
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16. The Logo image should still be selected.  (Dotted lines surrounding the image)  Once 
again use the Edit>Copy function to place a copy of our logo on the clipboard. 

17. Make our blue masked image (the fancy looking one) the active image and paste the logo 
onto the top of the mask and center it. 

 

 
 

18. Right click on the image and set the shadow option to lift it from the surface of the 
masked background image. 

19. Again save this image as LogoMasked.ufo.  If you were going to use this image in either 
a document or on a web page, you would want to save it again as a .jpg file. 
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